Bill Pay Scheduled Payment Error
Incident Report for Converse County Bank
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 17:48 MST
Investigating
We are currently investigating an issue where users may receive a "Failed to get template delivery dates" error when using Bill Pay.
Posted Feb 11, 2021 - 17:04 MST
This incident affected: 🧾 Bill Pay.