Online and Mobile Banking Outage
Incident Report for Converse County Bank
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 21:30 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2020 - 21:08 MDT
Identified
We are currently aware of an outage affecting Online and Mobile Banking. We are working to resolve this issue and will continue to provide updates. We apologize for any inconvenience.
Posted Oct 28, 2020 - 20:44 MDT
This incident affected: 🖥️ Online Banking and 📱 Mobile Banking.