Live Chat Outage
Incident Report for Converse County Bank
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 14:12 MDT
Investigating
We are currently aware of an outage affecting Live Chat on our website, as well as mobile messaging. We are working to resolve this issue and will continue to provide updates. We apologize for any inconvenience.
Posted Jun 07, 2021 - 12:44 MDT
This incident affected: 💬 Live Chat.